dolittle_use

ドリトルを使う(使用方法)

  • Bit Arrowでドリトルのプログラムを学習できます。

起動方法

共通の説明もあわせてご覧ください)

1.Bit Arrowを開く

2.初めてログインする

Bit Arrowを初めて使うときや長期間使わずログアウトしているときは、ダイアログが表示されます。

login1

OKを押すと、ログイン画面が表示されます。

login2

  • 個人で使う場合は、クラスIDに「guest」を、ユーザー名に任意のユーザ名を英数字で入れてください。(説明のためにここではユーザー名を「bitarrow」とする。)
  • 授業で使う場合は、先生から指定されたクラスIDとユーザー名を入れてください。
  • ユーザー名には、半角英数字とハイフン(-)、アンダースコア(_)だけが使えます。

login3

3.プログラムを作成する

  • ログインするとHome画面が表示されます。プログラムを作るために、最初にプロジェクトを作ります。「新規プロジェクト」を選択してください。
  • 新規プロジェクトダイアログが表示されます。英数字でプロジェクト名を入れてください。プログラミング言語が「ドリトル」になっていることを確認して、「OK」を押しましょう。
  • 新しいプログラムを作るときは、「ファイル」から「新規」を選択します。
  • ファイル名には半角英数字を入れてください。先頭の英字は自動的に大文字になります。
  • ドリトルのプログラムの書き方について詳しくは「マニュアルページ」をご覧ください。
  • 従来のドリトル(Java版)との違いは以下の情報をご覧ください。

2016年8月時点の対応状況

言語の変更点

タイマー

  • タイマーの実行が終るのを待ってから次の処理を行うときの書き方が変わりました。
    • 新しい書き方はJava版のドリトル(V2.39以降)でも使用できます。
  • 従来の書き方(タートルが10秒間回転した後、100歩あるきます)
    • 「待つ」で、時計の実行が終了するまで処理がプログラムの処理が止まります。
      時計=タイマー!作る。
      時計!「かめた!10 左回り」実行。
      時計!待つ。
      かめた!100 歩く。
  • 新しい書き方(タートルが20秒間回転した後、100歩あるきます)
    • 「次に実行」で、前の「実行」に続いてタイマーを実行します。
    • 「最後に実行」で、前の「実行」や「次に実行」に続いて、1回だけ実行します。
      時計=タイマー!作る。
      時計!「かめた!10 左回り」実行。
      時計!「かめた!10 左回り」次に実行。
      時計!「かめた!100 歩く」最後に実行。

その他

  • 一部のオブジェクトではプロパティの利用や継承が行われません。(数値、文字列、真偽値、配列、ブロック)

powered by Quick Homepage Maker 5.1
based on PukiWiki 1.4.7 License is GPL. QHM

最新の更新 RSS  Valid XHTML 1.0 Transitional